# CVE-2023-36478: HTTP/2 HPACK integer overflow and buffer allocation

> Remote attackers can cause denial of service in Jetty HTTP/2 servers by triggering an integer overflow that leads to excessive buffer allocation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-jenkins-2023-36478, DEBIAN-CVE-2023-36478, GHSA-wgh7-54f2-x98r, UBUNTU-CVE-2023-36478

## What is CVE-2023-36478?

CVE-2023-36478 is a high-severity vulnerability in Debian Debian Linux, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to
exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295
will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-36478?

11 open source packages ship an affected version, including org.eclipse.jetty.http2:http2-hpack, jenkins and org.eclipse.jetty.http3:http3-qpack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 9.3.0 | 9.4.53 |
| `org.eclipse.jetty.http2:http2-hpack` | Maven | From 9.3.0 | 9.4.53 |
| `jenkins` | Bitnami | All versions | 2.428.0 |
| `org.eclipse.jetty.http3:http3-qpack` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty.http3:http3-qpack` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty.http3:http3-qpack` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty.http3:http3-qpack` | Maven | From 11.0.0 | 11.0.16 |

Products: Debian Debian Linux, Eclipse Jetty, Jenkins Jenkins.

## How do I fix CVE-2023-36478?

Upgrade org.eclipse.jetty.http2:http2-hpack to a fixed version for your release line: 10.0.16, 11.0.16 or 9.4.53.

## Is CVE-2023-36478 being exploited?

There is no known exploitation of CVE-2023-36478 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36478 and fix it if it is affected.

What it is: CVE-2023-36478 is a high-severity vulnerability in Debian Debian Linux, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36478 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 9.3.0; fixed in 9.4.53
- org.eclipse.jetty.http2:http2-hpack (Maven): affected from 9.3.0; fixed in 9.4.53
- jenkins (Bitnami): affected all versions; fixed in 2.428.0
- org.eclipse.jetty.http3:http3-qpack (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty.http3:http3-qpack (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty.http3:http3-qpack (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty.http3:http3-qpack (Maven): affected from 11.0.0; fixed in 11.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36478/ (Markdown: https://insights.sbomify.com/CVE-2023-36478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36478
- OSV: https://osv.dev/vulnerability/CVE-2023-36478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36478/
Summaries are generated and may contain mistakes; the official description above is the record.
