# CVE-2023-36542: Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nifi-2023-36542, GHSA-r969-8v3h-23v9

## What is CVE-2023-36542?

CVE-2023-36542 is a high-severity vulnerability in Apache Nifi, published on 29 Jul 2023. 

### Official description

Apache NiFi 0.0.2 through 1.22.0 include Processors and Controller Services that support HTTP URL references for retrieving drivers, which allows an authenticated and authorized user to configure a location that enables custom code execution. The resolution introduces a new Required Permission for referencing remote resources, restricting configuration of these components to privileged users. The permission prevents unprivileged users from configuring Processors and Controller Services annotated with the new Reference Remote Resources restriction. Upgrading to Apache NiFi 1.23.0 is the recommended mitigation.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-36542?

17 open source packages ship an affected version, including org.apache.nifi:nifi-cdc-mysql-bundle, nifi and org.apache.nifi:nifi-dbcp-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-cdc-mysql-bundle` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-cdc-mysql-bundle` | Maven | From 0.0.2 | 1.23.0 |
| `nifi` | Bitnami | From 0.0.2 to 1.22.0 | None |
| `org.apache.nifi:nifi-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hadoop-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hadoop-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hbase_2-client-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hbase_2-client-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hikari-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-hikari-dbcp-service` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-record-serialization-services` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-record-serialization-services` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-standard-processors` | Maven | From 0.0.2 | 1.23.0 |
| `org.apache.nifi:nifi-standard-processors` | Maven | From 0.0.2 | 1.23.0 |

Products: Apache Nifi.

## How do I fix CVE-2023-36542?

Upgrade org.apache.nifi:nifi-cdc-mysql-bundle to 1.23.0 or later.

## Is CVE-2023-36542 being exploited?

There is no known exploitation of CVE-2023-36542 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/asf__nifi_CVE-2023-36542_1-22-0 (github_poc): https://github.com/shoucheng3/asf__nifi_CVE-2023-36542_1-22-0

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-34468](https://insights.sbomify.com/CVE-2023-34468/): Apache NiFi: Potential Code Injection with Database Services using H2 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36542 and fix it if it is affected.

What it is: CVE-2023-36542 is a high-severity vulnerability in Apache Nifi, published on 29 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2023-36542 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-cdc-mysql-bundle (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-cdc-mysql-bundle (Maven): affected from 0.0.2; fixed in 1.23.0
- nifi (Bitnami): affected from 0.0.2 up to 1.22.0; no fix listed
- org.apache.nifi:nifi-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hadoop-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hadoop-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hbase_2-client-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hbase_2-client-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hikari-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-hikari-dbcp-service (Maven): affected from 0.0.2; fixed in 1.23.0
- org.apache.nifi:nifi-jms-processors (Maven): affected from 0.0.2; fixed in 1.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36542/ (Markdown: https://insights.sbomify.com/CVE-2023-36542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36542
- OSV: https://osv.dev/vulnerability/CVE-2023-36542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36542/
Summaries are generated and may contain mistakes; the official description above is the record.
