{"answers":{"affected":"8 open source packages ship an affected version, including uri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-36617 in the wild and no public exploit code.","fix":"Upgrade uri to a fixed version for your release line: 0.10.0.3, 0.10.3, 0.11.2 or 0.12.2.","what":"CVE-2023-36617 is a medium-severity denial of service vulnerability in n/a, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36617 and fix it if it is affected.\n\nWhat it is: CVE-2023-36617 is a medium-severity denial of service vulnerability in n/a, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-36617 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uri (RubyGems): affected all versions; fixed in 0.10.0.3\n- uri (RubyGems): affected all versions; fixed in 0.10.0.3\n- uri (RubyGems): affected from 0.10.1; fixed in 0.10.3\n- uri (RubyGems): affected from 0.10.1; fixed in 0.10.3\n- uri (RubyGems): affected from 0.11.0; fixed in 0.11.2\n- uri (RubyGems): affected from 0.11.0; fixed in 0.11.2\n- uri (RubyGems): affected from 0.12.0; fixed in 0.12.2\n- uri (RubyGems): affected from 0.12.0; fixed in 0.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36617/ (Markdown: https://insights.sbomify.com/CVE-2023-36617/index.md)","id":"CVE-2023-36617","markdown":"https://insights.sbomify.com/CVE-2023-36617/index.md","name":"CVE-2023-36617","record":{"aliases":["AZL-27310","CLSA-2025-1755617966","DEBIAN-CVE-2023-36617","GHSA-hww2-5g85-429m","OESA-2023-1427","UBUNTU-CVE-2023-36617","USN-7747-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby URI library","requires_auth":"none","summary":"Attackers can cause denial of service by submitting specially crafted URLs that trigger excessive parsing time in the Ruby URI library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"uri","vendor":"ruby-lang"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396_parser.rb and rfc3986_parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"URI gem has ReDoS vulnerability","id":"CVE-2023-36617","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":8,"n_references":4,"next":{"headline":"Command injection in n/a","id":"CVE-2023-36618"},"packages":[{"ecosystem":"RubyGems","fixed":["0.10.0.3"],"introduced":["0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.10.0.3"],"introduced":["0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.10.3"],"introduced":["0.10.1"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.10.3"],"introduced":["0.10.1"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.11.2"],"introduced":["0.11.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.11.2"],"introduced":["0.11.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.12.2"],"introduced":["0.12.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-hww2-5g85-429m"},{"ecosystem":"RubyGems","fixed":["0.12.2"],"introduced":["0.12.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-hww2-5g85-429m"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2023-36612"},"products":["n/a"],"published":"2023-06-29","related":[{"cvss_score":3.2,"headline":"URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+","id":"CVE-2025-27221","kev_date_added":null,"published":"2025-03-03"},{"cvss_score":2.1,"headline":"URI Credential Leakage Bypass over CVE-2025-27221","id":"CVE-2025-61594","kev_date_added":null,"published":"2025-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Attackers can cause denial of service by submitting specially crafted URLs that trigger excessive parsing time in the Ruby URI library.","url":"https://insights.sbomify.com/CVE-2023-36617/"}