# CVE-2023-36617: URI gem has ReDoS vulnerability

> Attackers can cause denial of service by submitting specially crafted URLs that trigger excessive parsing time in the Ruby URI library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2023
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-27310, CLSA-2025-1755617966, DEBIAN-CVE-2023-36617, GHSA-hww2-5g85-429m, OESA-2023-1427, UBUNTU-CVE-2023-36617, USN-7747-1

## What is CVE-2023-36617?

CVE-2023-36617 is a medium-severity denial of service vulnerability in n/a, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396_parser.rb and rfc3986_parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-36617?

8 open source packages ship an affected version, including uri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uri` | RubyGems | All versions | 0.10.0.3 |
| `uri` | RubyGems | All versions | 0.10.0.3 |
| `uri` | RubyGems | From 0.10.1 | 0.10.3 |
| `uri` | RubyGems | From 0.10.1 | 0.10.3 |
| `uri` | RubyGems | From 0.11.0 | 0.11.2 |
| `uri` | RubyGems | From 0.11.0 | 0.11.2 |
| `uri` | RubyGems | From 0.12.0 | 0.12.2 |
| `uri` | RubyGems | From 0.12.0 | 0.12.2 |

Products: Ruby-Lang Uri.

## How do I fix CVE-2023-36617?

Upgrade uri to a fixed version for your release line: 0.10.0.3, 0.10.3, 0.11.2 or 0.12.2.

## Is CVE-2023-36617 being exploited?

There is no known exploitation of CVE-2023-36617 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-27221](https://insights.sbomify.com/CVE-2025-27221/): URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+ (low 3.2)
- [CVE-2025-61594](https://insights.sbomify.com/CVE-2025-61594/): URI Credential Leakage Bypass over CVE-2025-27221 (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36617 and fix it if it is affected.

What it is: CVE-2023-36617 is a medium-severity denial of service vulnerability in n/a, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36617 in the wild and no public exploit code.

Affected packages and fixed versions:
- uri (RubyGems): affected all versions; fixed in 0.10.0.3
- uri (RubyGems): affected all versions; fixed in 0.10.0.3
- uri (RubyGems): affected from 0.10.1; fixed in 0.10.3
- uri (RubyGems): affected from 0.10.1; fixed in 0.10.3
- uri (RubyGems): affected from 0.11.0; fixed in 0.11.2
- uri (RubyGems): affected from 0.11.0; fixed in 0.11.2
- uri (RubyGems): affected from 0.12.0; fixed in 0.12.2
- uri (RubyGems): affected from 0.12.0; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36617/ (Markdown: https://insights.sbomify.com/CVE-2023-36617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36617
- OSV: https://osv.dev/vulnerability/CVE-2023-36617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36617/
Summaries are generated and may contain mistakes; the official description above is the record.
