{"answers":{"affected":"3 open source packages ship an affected version, including libpython, python and python-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36632 exists.","fix":"Upgrade libpython to 3.11.5 or later.","what":"CVE-2023-36632 is a high-severity denial of service vulnerability in Python Python, published on 25 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36632 and fix it if it is affected.\n\nWhat it is: CVE-2023-36632 is a high-severity denial of service vulnerability in Python Python, published on 25 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36632 exists.\n\nAffected packages and fixed versions:\n- libpython (Bitnami): affected all versions; fixed in 3.11.5\n- python (Bitnami): affected all versions; fixed in 3.11.5\n- python-min (Bitnami): affected all versions; fixed in 3.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36632/ (Markdown: https://insights.sbomify.com/CVE-2023-36632/index.md)","id":"CVE-2023-36632","markdown":"https://insights.sbomify.com/CVE-2023-36632/index.md","name":"CVE-2023-36632","record":{"aliases":["AZL-109665","BIT-libpython-2023-36632","BIT-python-2023-36632","BIT-python-min-2023-36632","ECHO-f330-0e36-0681","GHSA-gv66-v8c8-v69c","MINI-w64c-fj8j-jm38","PSF-2023-4"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python standard library","requires_auth":"none","summary":"Attackers can cause a denial of service via recursion error in Python's legacy email parsing function using crafted input.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"python","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The legacy email.utils.parseaddr function in Python through 3.11.4 allows attackers to trigger \"RecursionError: maximum recursion depth exceeded while calling a Python object\" via a crafted argument. This argument is plausibly an untrusted value from an application's input data that was supposed to contain a name and an e-mail address. NOTE: email.utils.parseaddr is categorized as a Legacy API in the documentation of the Python email package. Applications should instead use the email.parser.BytesParser or email.parser.Parser class. NOTE: the vendor's perspective is that this is neither a vulnerability nor a bug. The email package is intended to have size limits and to throw an exception when limits are exceeded; they were exceeded by the example demonstration code.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-36632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"python:python","products":["python:python"],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Missing authorization in FortiMail","id":"CVE-2023-36633"},"packages":[{"ecosystem":"Bitnami","fixed":["3.11.5"],"introduced":["0"],"last_affected":[],"package":"libpython","purl":"pkg:bitnami/libpython","source":"BIT-libpython-2023-36632"},{"ecosystem":"Bitnami","fixed":["3.11.5"],"introduced":["0"],"last_affected":[],"package":"python","purl":"pkg:bitnami/python","source":"BIT-python-2023-36632"},{"ecosystem":"Bitnami","fixed":["3.11.5"],"introduced":["0"],"last_affected":[],"package":"python-min","purl":"pkg:bitnami/python-min","source":"BIT-python-min-2023-36632"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2023-36631"},"products":["n/a"],"published":"2023-06-25","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-5031","kev_date_added":null,"published":"2008-11-10"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2014-4650","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-5636","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2007-4559","kev_date_added":null,"published":"2007-08-28"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2017-17522","kev_date_added":null,"published":"2017-12-14"},{"cvss_score":8.7,"headline":"Incremental HTMLParser feed() allows CPU-exhaustion DoS via repeated unterminated markup declarations","id":"CVE-2026-15308","kev_date_added":null,"published":"2026-07-09"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2019-13404","kev_date_added":null,"published":"2019-07-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via recursion error in Python's legacy email parsing function using crafted input.","url":"https://insights.sbomify.com/CVE-2023-36632/"}