CVE-2023-36675 Cross-site scripting in n/a
Cross-site scripting vulnerability in MediaWiki's partial blocks feature allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-36675?
CVE-2023-36675 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 26 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.11, 1.36.x through 1.38.x before 1.38.7, and 1.39.x before 1.39.4. BlockLogFormatter.php in BlockLogFormatter allows XSS in the partial blocks feature.
Weakness: CWE-79
Which versions are affected by CVE-2023-36675?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.11, 1.38.7, 1.39.4 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2023-36675?
Upgrade mediawiki to a fixed version for your release line: 1.35.11, 1.38.7 or 1.39.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-36675 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36675 exists.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2023-36675, DEBIAN-CVE-2023-36675, GHSA-q7gg-775p-p35h, UBUNTU-CVE-2023-36675.