# CVE-2023-3674: Keylime: attestation failure when the quote's signature does not validate

> Keylime fails to flag devices with invalid TPM quote signatures as untrusted, allowing bypass of attestation security controls.

- **Severity:** Low 2.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2023
- **Updated:** 21 Nov 2025
- **Also known as:** ALSA-2024:1139, GHSA-g4wg-cfpf-9689, PYSEC-2023-128, RHSA-2024:1139, RLSA-2024:1139, openSUSE-SU-2024:14051-1

## What is CVE-2023-3674?

CVE-2023-3674 is a low-severity vulnerability in Fedoraproject Fedora, published on 19 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in the keylime attestation verifier, which fails to flag a device's submitted TPM quote as faulty when the quote's signature does not validate for some reason. Instead, it will only emit an error in the log without flagging the device as untrusted.

Weakness: CWE-1283 (Mutable Attestation or Measurement Reporting Data)

## Which versions are affected by CVE-2023-3674?

3 open source packages ship an affected version, including keylime. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keylime` | PyPI | All versions | 7.2.5 |
| `keylime` | PyPI | All versions | 7.2.5 |
| `keylime` | PyPI | All versions | 7.2.5 |
| `keylime` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime-base` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime-registrar` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime-selinux` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime-tenant` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime-verifier` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `python3-keylime` | AlmaLinux:9 | All versions | 7.3.0-13.el9_3 |
| `keylime` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime-base` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime-registrar` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime-selinux` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime-tenant` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime-verifier` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `python3-keylime` | Red Hat:enterprise_linux:9::appstream | All versions | 0:7.3.0-13.el9_3 |
| `keylime` | Rocky Linux:9 | All versions | 0:7.3.0-13.el9_3 |
| `keylime` | openSUSE:Tumbleweed | All versions | 7.11.0-1.1 |

Products: Fedoraproject Fedora, Keylime Keylime.

## How do I fix CVE-2023-3674?

Upgrade keylime to 7.2.5 or later.

## Is CVE-2023-3674 being exploited?

There is no known exploitation of CVE-2023-3674 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3674 and fix it if it is affected.

What it is: CVE-2023-3674 is a low-severity vulnerability in Fedoraproject Fedora, published on 19 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3674 in the wild and no public exploit code.

Affected packages and fixed versions:
- keylime (PyPI): affected all versions; fixed in 7.2.5
- keylime (PyPI): affected all versions; fixed in 7.2.5
- keylime (PyPI): affected all versions; fixed in 7.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3674/ (Markdown: https://insights.sbomify.com/CVE-2023-3674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3674
- OSV: https://osv.dev/vulnerability/CVE-2023-3674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3674/
Summaries are generated and may contain mistakes; the official description above is the record.
