CVE-2023-36806 Contao cross site scripting vulnerability via input unit widget
Untrusted backend users can inject malicious scripts into headline fields, leading to code execution in both backend and frontend views.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-36806?
CVE-2023-36806 is a medium-severity cross-site scripting vulnerability in contao, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.
Weakness: CWE-79
Which versions are affected by CVE-2023-36806?
6 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/core-bundle Packagist | From 4.0.0 | 4.9.42 |
contao/core-bundle Packagist | From 4.0.0 | 4.9.42 |
contao/core-bundle Packagist | From 4.10.0 | 4.13.28 |
contao/core-bundle Packagist | From 4.10.0 | 4.13.28 |
contao/core-bundle Packagist | From 5.0.0 | 5.1.10 |
contao/core-bundle Packagist | From 5.0.0 | 5.1.10 |
Products include Contao Contao.
How do I fix CVE-2023-36806?
Upgrade contao/core-bundle to a fixed version for your release line: 4.9.42, 4.13.28 or 5.1.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-36806 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36806 exists.
Other vulnerabilities in contao
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-4gpr-p634-922x.