# CVE-2023-36806: Contao cross site scripting vulnerability via input unit widget

> Untrusted backend users can inject malicious scripts into headline fields, leading to code execution in both backend and frontend views.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-4gpr-p634-922x

## What is CVE-2023-36806?

CVE-2023-36806 is a medium-severity cross-site scripting vulnerability in contao, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-36806?

6 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.9.42 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.9.42 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.13.28 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.13.28 |
| `contao/core-bundle` | Packagist | From 5.0.0 | 5.1.10 |
| `contao/core-bundle` | Packagist | From 5.0.0 | 5.1.10 |

Products: Contao Contao.

## How do I fix CVE-2023-36806?

Upgrade contao/core-bundle to a fixed version for your release line: 4.9.42, 4.13.28 or 5.1.10.

## Is CVE-2023-36806 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36806 exists.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36806 and fix it if it is affected.

What it is: CVE-2023-36806 is a medium-severity cross-site scripting vulnerability in contao, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36806 exists.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.9.42
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.9.42
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.13.28
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.13.28
- contao/core-bundle (Packagist): affected from 5.0.0; fixed in 5.1.10
- contao/core-bundle (Packagist): affected from 5.0.0; fixed in 5.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36806/ (Markdown: https://insights.sbomify.com/CVE-2023-36806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36806
- OSV: https://osv.dev/vulnerability/CVE-2023-36806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36806/
Summaries are generated and may contain mistakes; the official description above is the record.
