# CVE-2023-36813: Kanboard Authenticated SQL Injections vulnerability

> An authenticated user can perform SQL injection in Kanboard, leading to privilege escalation or data confidentiality loss.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DSA-5454-1, GHSA-9gvq-78jp-jxcx, MGASA-2024-0366

## What is CVE-2023-36813?

CVE-2023-36813 is a high-severity SQL injection vulnerability in kanboard, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kanboard is project management software that focuses on the Kanban methodology. In versions prior to 1.2.31authenticated user is able to perform a SQL Injection, leading to a privilege escalation or loss of confidentiality. It appears that in some insert and update operations, the code improperly uses the PicoDB library to update/insert new information. Version 1.2.31 contains a fix for this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-36813?

It affects 1 product.


Products: Kanboard Kanboard.

## How do I fix CVE-2023-36813?

Upgrade to a fixed version.

## Is CVE-2023-36813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36813 exists.

## Other vulnerabilities in kanboard

- [CVE-2026-21881](https://insights.sbomify.com/CVE-2026-21881/): Kanboard is Vulnerable to Reverse Proxy Authentication Bypass (critical 9.1)
- [CVE-2025-55010](https://insights.sbomify.com/CVE-2025-55010/): Kanboard Authenticated Admin Remote Code Execution via Unsafe Deserialization of Events (critical 9.1)
- [CVE-2024-51747](https://insights.sbomify.com/CVE-2024-51747/): Arbitrary File Read and Delete in kanboard (critical 9.1)
- [CVE-2024-51748](https://insights.sbomify.com/CVE-2024-51748/): Remote code execution through language setting in kanboard (critical 9.1)
- [CVE-2017-12850](https://insights.sbomify.com/CVE-2017-12850/): Business logic in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36813 and fix it if it is affected.

What it is: CVE-2023-36813 is a high-severity SQL injection vulnerability in kanboard, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36813 exists.

Affected product: kanboard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36813/ (Markdown: https://insights.sbomify.com/CVE-2023-36813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36813
- OSV: https://osv.dev/vulnerability/CVE-2023-36813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36813/
Summaries are generated and may contain mistakes; the official description above is the record.
