{"answers":{"affected":"1 open source package ship an affected version, including discourse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-36818 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-36818 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-36818 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 14 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36818 and fix it if it is affected.\n\nWhat it is: CVE-2023-36818 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 14 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-36818 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected from 3.1.0-beta5 up to 3.1.0-beta5; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36818/ (Markdown: https://insights.sbomify.com/CVE-2023-36818/index.md)","id":"CVE-2023-36818","markdown":"https://insights.sbomify.com/CVE-2023-36818/index.md","name":"CVE-2023-36818","record":{"aliases":["BIT-discourse-2023-36818","GHSA-gxqx-3q2p-37gm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Discourse forum","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in Discourse by creating unlimited links in custom sidebar sections, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"discourse","vendor":"discourse"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Discourse is an open source discussion platform. In affected versions a request to create or update custom sidebar section can cause a denial of service. This issue has been patched in commit `52b003d915`. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Denial of service via User Custom Sidebar Section Unlimited Link Creation in discourse","id":"CVE-2023-36818","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"discourse:discourse","products":["discourse:discourse"],"type":"denial_of_service","year":"2023"},"n_packages":1,"n_references":2,"next":{"headline":"Knowage-Server vulnerable to Path traversal in download functionalities","id":"CVE-2023-36819"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["3.1.0-beta5"],"last_affected":["3.1.0-beta5"],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2023-36818"}],"prev":{"headline":"The King's Temple Church website Leaked Stripe API Key in Public Code Repository","id":"CVE-2023-36817"},"products":["discourse"],"published":"2023-07-14","related":[{"cvss_score":10,"headline":"RCE via malicious SNS subscription payload","id":"CVE-2021-41163","kev_date_added":null,"published":"2021-10-20"},{"cvss_score":9.1,"headline":"Discourse vulnerable to RCE via admins uploading maliciously zipped file","id":"CVE-2022-36066","kev_date_added":null,"published":"2022-09-29"},{"cvss_score":8.9,"headline":"Discourse user account takeover via email and invite link","id":"CVE-2022-39356","kev_date_added":null,"published":"2022-11-02"},{"cvss_score":8.8,"headline":"Discourse vulnerable to Cross-site Scripting in local oneboxes","id":"CVE-2023-22468","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":8.7,"headline":"Discourse leaks private topic title and post excerpt via user action API endpoint","id":"CVE-2026-27934","kev_date_added":null,"published":"2026-03-19"},{"cvss_score":8.7,"headline":"Discourse vulnerable to DoS via large URL payload in PM to a bot","id":"CVE-2025-48053","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.6,"headline":"Discourse vulnerable to unlimited mentioned users in message serializer","id":"CVE-2023-48297","kev_date_added":null,"published":"2024-01-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-18","vendors":["discourse"]},"summary":"Attackers can cause denial of service in Discourse by creating unlimited links in custom sidebar sections, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-36818/"}