{"answers":{"affected":"2 open source packages ship an affected version, including uptime-kuma. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36821 exists.","fix":"Upgrade uptime-kuma to 1.22.1 or later.","what":"CVE-2023-36821 is a high-severity code injection vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36821 and fix it if it is affected.\n\nWhat it is: CVE-2023-36821 is a high-severity code injection vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36821 exists.\n\nAffected packages and fixed versions:\n- uptime-kuma (npm): affected all versions; fixed in 1.22.1\n- uptime-kuma (npm): affected all versions; fixed in 1.22.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36821/ (Markdown: https://insights.sbomify.com/CVE-2023-36821/index.md)","id":"CVE-2023-36821","markdown":"https://insights.sbomify.com/CVE-2023-36821/index.md","name":"CVE-2023-36821","record":{"aliases":["GHSA-7grx-f945-mj96"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Uptime Kuma monitoring tool","requires_auth":"low_privilege","summary":"Authenticated attackers can achieve remote code execution by installing malicious plugins via exposed API endpoints that bypass validation and execute npm scripts.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uptime-kuma","vendor":"uptime-kuma_project"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Uptime Kuma, a self-hosted monitoring tool, allows an authenticated attacker to install a maliciously crafted plugin in versions prior to 1.22.1, which may lead to remote code execution. Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. After downloading a plugin, it's installed by calling `npm install` in the installation directory of the plugin. Because the plugin is not validated against the official list of plugins or installed with `npm install --ignore-scripts`, a maliciously crafted plugin taking advantage of npm scripts can gain remote code execution. Version 1.22.1 contains a patch for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation","id":"CVE-2023-36821","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss","id":"CVE-2023-36822"},"packages":[{"ecosystem":"npm","fixed":["1.22.1"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":null,"source":"GHSA-7grx-f945-mj96"},{"ecosystem":"npm","fixed":["1.22.1"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":"pkg:npm/uptime-kuma","source":"GHSA-7grx-f945-mj96"}],"prev":{"headline":"micronaut security has invalid IdTokenClaimsValidator logic on aud","id":"CVE-2023-36820"},"products":["uptime-kuma"],"published":"2023-07-05","related":[{"cvss_score":6.5,"headline":"Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss","id":"CVE-2023-36822","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.3,"headline":"Persistent Cross site scripting (XSS) through description in status page in Uptime Kuma","id":"CVE-2023-25810","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":6.3,"headline":"Persistent Cross site scripting (XSS) in Uptime Kuma","id":"CVE-2023-25811","kev_date_added":null,"published":"2023-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-18","vendors":["louislam"]},"summary":"Authenticated attackers can achieve remote code execution by installing malicious plugins via exposed API endpoints that bypass validation and execute npm scripts.","url":"https://insights.sbomify.com/CVE-2023-36821/"}