# CVE-2023-36821: Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation

> Authenticated attackers can achieve remote code execution by installing malicious plugins via exposed API endpoints that bypass validation and execute npm scripts.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-7grx-f945-mj96

## What is CVE-2023-36821?

CVE-2023-36821 is a high-severity code injection vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Uptime Kuma, a self-hosted monitoring tool, allows an authenticated attacker to install a maliciously crafted plugin in versions prior to 1.22.1, which may lead to remote code execution. Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. After downloading a plugin, it's installed by calling `npm install` in the installation directory of the plugin. Because the plugin is not validated against the official list of plugins or installed with `npm install --ignore-scripts`, a maliciously crafted plugin taking advantage of npm scripts can gain remote code execution. Version 1.22.1 contains a patch for this issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-36821?

2 open source packages ship an affected version, including uptime-kuma. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uptime-kuma` | npm | All versions | 1.22.1 |
| `uptime-kuma` | npm | All versions | 1.22.1 |

Products: Uptime-Kuma Project Uptime-Kuma.

## How do I fix CVE-2023-36821?

Upgrade uptime-kuma to 1.22.1 or later.

## Is CVE-2023-36821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36821 exists.

## Other vulnerabilities in louislam uptime-kuma

- [CVE-2023-36822](https://insights.sbomify.com/CVE-2023-36822/): Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss (medium 6.5)
- [CVE-2023-25810](https://insights.sbomify.com/CVE-2023-25810/): Persistent Cross site scripting (XSS) through description in status page in Uptime Kuma (medium 6.3)
- [CVE-2023-25811](https://insights.sbomify.com/CVE-2023-25811/): Persistent Cross site scripting (XSS) in Uptime Kuma (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36821 and fix it if it is affected.

What it is: CVE-2023-36821 is a high-severity code injection vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36821 exists.

Affected packages and fixed versions:
- uptime-kuma (npm): affected all versions; fixed in 1.22.1
- uptime-kuma (npm): affected all versions; fixed in 1.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36821/ (Markdown: https://insights.sbomify.com/CVE-2023-36821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36821
- OSV: https://osv.dev/vulnerability/CVE-2023-36821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36821/
Summaries are generated and may contain mistakes; the official description above is the record.
