{"answers":{"affected":"2 open source packages ship an affected version, including uptime-kuma. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36822 exists.","fix":"Upgrade uptime-kuma to 1.22.1 or later.","what":"CVE-2023-36822 is a medium-severity path traversal vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36822 and fix it if it is affected.\n\nWhat it is: CVE-2023-36822 is a medium-severity path traversal vulnerability in louislam uptime-kuma, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36822 exists.\n\nAffected packages and fixed versions:\n- uptime-kuma (npm): affected all versions; fixed in 1.22.1\n- uptime-kuma (npm): affected all versions; fixed in 1.22.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36822/ (Markdown: https://insights.sbomify.com/CVE-2023-36822/index.md)","id":"CVE-2023-36822","markdown":"https://insights.sbomify.com/CVE-2023-36822/index.md","name":"CVE-2023-36822","record":{"aliases":["GHSA-vr8x-74pm-6vj7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Uptime Kuma monitoring tool","requires_auth":"low_privilege","summary":"Authenticated attackers can delete arbitrary server files via path traversal in plugin installation, causing system unavailability or data loss.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uptime-kuma","vendor":"uptime-kuma_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Uptime Kuma, a self-hosted monitoring tool, has a path traversal vulnerability in versions prior to 1.22.1. Uptime Kuma allows authenticated users to install plugins from an official list of plugins. This feature is currently disabled in the web interface, but the corresponding API endpoints are still available after login. Before a plugin is downloaded, the plugin installation directory is checked for existence. If it exists, it's removed before the plugin installation. Because the plugin is not validated against the official list of plugins or sanitized, the check for existence and the removal of the plugin installation directory are prone to path traversal. This vulnerability allows an authenticated attacker to delete files from the server Uptime Kuma is running on. Depending on which files are deleted, Uptime Kuma or the whole system may become unavailable due to data loss.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss","id":"CVE-2023-36822","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content","id":"CVE-2023-36823"},"packages":[{"ecosystem":"npm","fixed":["1.22.1"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":null,"source":"GHSA-vr8x-74pm-6vj7"},{"ecosystem":"npm","fixed":["1.22.1"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":"pkg:npm/uptime-kuma","source":"GHSA-vr8x-74pm-6vj7"}],"prev":{"headline":"Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation","id":"CVE-2023-36821"},"products":["uptime-kuma"],"published":"2023-07-05","related":[{"cvss_score":8.8,"headline":"Uptime Kuma vulnerable to authenticated remote code execution via malicious plugin installation","id":"CVE-2023-36821","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.3,"headline":"Persistent Cross site scripting (XSS) through description in status page in Uptime Kuma","id":"CVE-2023-25810","kev_date_added":null,"published":"2023-02-21"},{"cvss_score":6.3,"headline":"Persistent Cross site scripting (XSS) in Uptime Kuma","id":"CVE-2023-25811","kev_date_added":null,"published":"2023-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-24","vendors":["louislam"]},"summary":"Authenticated attackers can delete arbitrary server files via path traversal in plugin installation, causing system unavailability or data loss.","url":"https://insights.sbomify.com/CVE-2023-36822/"}