{"answers":{"affected":"2 open source packages ship an affected version, including sanitize. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-36823 in the wild and no public exploit code.","fix":"Upgrade sanitize to 6.0.2 or later.","what":"CVE-2023-36823 is a high-severity vulnerability in Debian Debian Linux, published on 6 Jul 2023."},"fix_prompt":"Check this codebase for CVE-2023-36823 and fix it if it is affected.\n\nWhat it is: CVE-2023-36823 is a high-severity vulnerability in Debian Debian Linux, published on 6 Jul 2023. \nExploitation: There is no known exploitation of CVE-2023-36823 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize (RubyGems): affected from 3.0.0; fixed in 6.0.2\n- sanitize (RubyGems): affected from 3.0.0; fixed in 6.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36823/ (Markdown: https://insights.sbomify.com/CVE-2023-36823/index.md)","id":"CVE-2023-36823","markdown":"https://insights.sbomify.com/CVE-2023-36823/index.md","name":"CVE-2023-36823","record":{"aliases":["DEBIAN-CVE-2023-36823","DLA-3652-1","DSA-5616-1","GHSA-f5ww-cq3m-q3g7","UBUNTU-CVE-2023-36823"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"sanitize","vendor":"sanitize_project"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Sanitize is an allowlist-based HTML and CSS sanitizer. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML and CSS through Sanitize starting with version 3.0.0 and prior to version 6.0.2 when Sanitize is configured to use the built-in \"relaxed\" config or when using a custom config that allows `style` elements and one or more CSS at-rules. This could result in cross-site scripting or other undesired behavior when the malicious HTML and CSS are rendered in a browser. Sanitize 6.0.2 performs additional escaping of CSS in `style` element content, which fixes this issue. Users who are unable to upgrade can prevent this issue by using a Sanitize config that doesn't allow `style` elements, using a Sanitize config that doesn't allow CSS at-rules, or by manually escaping the character sequence `\u003c/` as `\u003c\\/` in `style` element content.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content","id":"CVE-2023-36823","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":null,"year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Heap overflow in COMMAND GETKEYS and ACL evaluation in Redis","id":"CVE-2023-36824"},"packages":[{"ecosystem":"RubyGems","fixed":["6.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":null,"source":"GHSA-f5ww-cq3m-q3g7"},{"ecosystem":"RubyGems","fixed":["6.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":"pkg:gem/sanitize","source":"GHSA-f5ww-cq3m-q3g7"}],"prev":{"headline":"Uptime Kuma authenticated path traversal via plugin repository name may lead to unavailability or data loss","id":"CVE-2023-36822"},"products":["sanitize"],"published":"2023-07-06","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["rgrove"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-36823/"}