# CVE-2023-36823: Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content


- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-36823, DLA-3652-1, DSA-5616-1, GHSA-f5ww-cq3m-q3g7, UBUNTU-CVE-2023-36823

## What is CVE-2023-36823?

CVE-2023-36823 is a high-severity vulnerability in Debian Debian Linux, published on 6 Jul 2023. 

### Official description

Sanitize is an allowlist-based HTML and CSS sanitizer. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML and CSS through Sanitize starting with version 3.0.0 and prior to version 6.0.2 when Sanitize is configured to use the built-in "relaxed" config or when using a custom config that allows `style` elements and one or more CSS at-rules. This could result in cross-site scripting or other undesired behavior when the malicious HTML and CSS are rendered in a browser. Sanitize 6.0.2 performs additional escaping of CSS in `style` element content, which fixes this issue. Users who are unable to upgrade can prevent this issue by using a Sanitize config that doesn't allow `style` elements, using a Sanitize config that doesn't allow CSS at-rules, or by manually escaping the character sequence `</` as `<\/` in `style` element content.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-36823?

2 open source packages ship an affected version, including sanitize. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize` | RubyGems | From 3.0.0 | 6.0.2 |
| `sanitize` | RubyGems | From 3.0.0 | 6.0.2 |

Products: Debian Debian Linux, Sanitize Project Sanitize.

## How do I fix CVE-2023-36823?

Upgrade sanitize to 6.0.2 or later.

## Is CVE-2023-36823 being exploited?

There is no known exploitation of CVE-2023-36823 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36823 and fix it if it is affected.

What it is: CVE-2023-36823 is a high-severity vulnerability in Debian Debian Linux, published on 6 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2023-36823 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize (RubyGems): affected from 3.0.0; fixed in 6.0.2
- sanitize (RubyGems): affected from 3.0.0; fixed in 6.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36823/ (Markdown: https://insights.sbomify.com/CVE-2023-36823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36823
- OSV: https://osv.dev/vulnerability/CVE-2023-36823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36823/
Summaries are generated and may contain mistakes; the official description above is the record.
