# CVE-2023-36825: Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution

> Attackers can achieve remote code execution by sending malicious data in the _state query parameter of the Orchid Laravel package.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-ph6g-p72v-pc3p

## What is CVE-2023-36825?

CVE-2023-36825 is a critical unsafe deserialization vulnerability in orchidsoftware platform, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-36825?

2 open source packages ship an affected version, including orchid/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `orchid/platform` | Packagist | From 14.0.0-alpha4 | 14.5.0 |
| `orchid/platform` | Packagist | From 14.0.0-alpha4 | 14.5.0 |

Products: Orchid Platform.

## How do I fix CVE-2023-36825?

Upgrade orchid/platform to 14.5.0 or later.

## Is CVE-2023-36825 being exploited?

There is no known exploitation of CVE-2023-36825 in the wild and no public exploit code.

## Other vulnerabilities in orchidsoftware platform

- [CVE-2020-15263](https://insights.sbomify.com/CVE-2020-15263/): XSS in platform (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36825 and fix it if it is affected.

What it is: CVE-2023-36825 is a critical unsafe deserialization vulnerability in orchidsoftware platform, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-36825 in the wild and no public exploit code.

Affected packages and fixed versions:
- orchid/platform (Packagist): affected from 14.0.0-alpha4; fixed in 14.5.0
- orchid/platform (Packagist): affected from 14.0.0-alpha4; fixed in 14.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36825/ (Markdown: https://insights.sbomify.com/CVE-2023-36825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36825
- OSV: https://osv.dev/vulnerability/CVE-2023-36825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36825/
Summaries are generated and may contain mistakes; the official description above is the record.
