CVE-2023-36826 Sentry vulnerable to improper authorization on debug and artifact file downloads
Authenticated users can download debug or artifact bundles from arbitrary projects without proper authorization, exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-36826?
CVE-2023-36826 is a high-severity missing authorization vulnerability in getsentry sentry, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
Which versions are affected by CVE-2023-36826?
3 open source packages ship an affected version, including sentry. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sentry PyPI | From 8.21.0 | 23.5.2 |
sentry PyPI | From 8.21.0 | 23.5.2 |
sentry PyPI | From 8.21.0 | 23.5.2 |
Products include Sentry Sentry.
How do I fix CVE-2023-36826?
Upgrade sentry to 23.5.2 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-36826 being exploited?
There is no known exploitation of CVE-2023-36826 in the wild and no public exploit code.
Other vulnerabilities in getsentry sentry
- CVE-2026-42354 Sentry: Improper authentication on SAML SSO process allows user identity linking
- CVE-2026-27197 Sentry: Improper Authentication on SAML SSO process allows user identity linking
- CVE-2021-47935 Sentry 8.2.0 Remote Code Execution via Pickle Deserialization
- CVE-2023-39349 Sentry vulnerable to privilege escalation via ApiTokensEndpoint
- CVE-2026-52794 Sentry: Inefficient Regular Expression Complexity in sentry
Sources
Also known as GHSA-m4hc-m2v6-hfw8, PYSEC-2023-130.