{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-36826 in the wild and no public exploit code.","fix":"Upgrade sentry to 23.5.2 or later.","what":"CVE-2023-36826 is a high-severity missing authorization vulnerability in getsentry sentry, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36826 and fix it if it is affected.\n\nWhat it is: CVE-2023-36826 is a high-severity missing authorization vulnerability in getsentry sentry, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-36826 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2\n- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2\n- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36826/ (Markdown: https://insights.sbomify.com/CVE-2023-36826/index.md)","id":"CVE-2023-36826","markdown":"https://insights.sbomify.com/CVE-2023-36826/index.md","name":"CVE-2023-36826","record":{"aliases":["GHSA-m4hc-m2v6-hfw8","PYSEC-2023-130"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Authenticated users can download debug or artifact bundles from arbitrary projects without proper authorization, exposing sensitive data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827"},"packages":[{"ecosystem":"PyPI","fixed":["23.5.2"],"introduced":["8.21.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-m4hc-m2v6-hfw8"},{"ecosystem":"PyPI","fixed":["23.5.2"],"introduced":["8.21.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-m4hc-m2v6-hfw8"},{"ecosystem":"PyPI","fixed":["23.5.2"],"introduced":["8.21.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2023-130"}],"prev":{"headline":"Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution","id":"CVE-2023-36825"},"products":["sentry"],"published":"2023-07-25","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["getsentry"]},"summary":"Authenticated users can download debug or artifact bundles from arbitrary projects without proper authorization, exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2023-36826/"}