# CVE-2023-36826: Sentry vulnerable to improper authorization on debug and artifact file downloads

> Authenticated users can download debug or artifact bundles from arbitrary projects without proper authorization, exposing sensitive data.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-m4hc-m2v6-hfw8, PYSEC-2023-130

## What is CVE-2023-36826?

CVE-2023-36826 is a high-severity missing authorization vulnerability in getsentry sentry, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2023-36826?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 8.21.0 | 23.5.2 |
| `sentry` | PyPI | From 8.21.0 | 23.5.2 |
| `sentry` | PyPI | From 8.21.0 | 23.5.2 |

Products: Sentry Sentry.

## How do I fix CVE-2023-36826?

Upgrade sentry to 23.5.2 or later.

## Is CVE-2023-36826 being exploited?

There is no known exploitation of CVE-2023-36826 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2026-52794](https://insights.sbomify.com/CVE-2026-52794/): Sentry: Inefficient Regular Expression Complexity in sentry (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36826 and fix it if it is affected.

What it is: CVE-2023-36826 is a high-severity missing authorization vulnerability in getsentry sentry, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36826 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2
- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2
- sentry (PyPI): affected from 8.21.0; fixed in 23.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36826/ (Markdown: https://insights.sbomify.com/CVE-2023-36826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36826
- OSV: https://osv.dev/vulnerability/CVE-2023-36826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36826/
Summaries are generated and may contain mistakes; the official description above is the record.
