{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-36827 in the wild and no public exploit code.","fix":"Upgrade ethyca-fides to 2.15.1 or later.","what":"CVE-2023-36827 is a high-severity path traversal vulnerability in ethyca fides, published on 5 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-36827 and fix it if it is affected.\n\nWhat it is: CVE-2023-36827 is a high-severity path traversal vulnerability in ethyca fides, published on 5 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-36827 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1\n- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36827/ (Markdown: https://insights.sbomify.com/CVE-2023-36827/index.md)","id":"CVE-2023-36827","markdown":"https://insights.sbomify.com/CVE-2023-36827/index.md","name":"CVE-2023-36827","record":{"aliases":["GHSA-r25m-cr6v-p9hq","PYSEC-2023-107"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy engineering platform","requires_auth":"none","summary":"Remote attackers can access arbitrary files on the Fides webserver container filesystem via path traversal in the API.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fides","vendor":"ethyca"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`.\n\nIf the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Statamic's Antlers sanitizer cannot effectively sanitize malicious SVG","id":"CVE-2023-36828"},"packages":[{"ecosystem":"PyPI","fixed":["2.15.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-r25m-cr6v-p9hq"},{"ecosystem":"PyPI","fixed":["2.15.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-r25m-cr6v-p9hq"},{"ecosystem":"PyPI","fixed":["2.15.1"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2023-107"}],"prev":{"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826"},"products":["fides"],"published":"2023-07-05","related":[{"cvss_score":9.1,"headline":"Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine","id":"CVE-2024-45053","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":8.8,"headline":"Remote Code Execution in Custom Integration Upload in Fides","id":"CVE-2023-41319","kev_date_added":null,"published":"2023-09-06"},{"cvss_score":8.6,"headline":"Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation","id":"CVE-2025-57817","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":8.2,"headline":"Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides","id":"CVE-2023-48224","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.2,"headline":"Server-Side Request Forgery Vulnerability in Custom Integration Upload","id":"CVE-2023-46124","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":6.5,"headline":"Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides","id":"CVE-2024-35189","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-24","vendors":["ethyca"]},"summary":"Remote attackers can access arbitrary files on the Fides webserver container filesystem via path traversal in the API.","url":"https://insights.sbomify.com/CVE-2023-36827/"}