# CVE-2023-36827: Fides vulnerable to Path Traversal in Webserver API

> Remote attackers can access arbitrary files on the Fides webserver container filesystem via path traversal in the API.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2023
- **Updated:** 24 Oct 2024
- **Also known as:** GHSA-r25m-cr6v-p9hq, PYSEC-2023-107

## What is CVE-2023-36827?

CVE-2023-36827 is a high-severity path traversal vulnerability in ethyca fides, published on 5 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`.

If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-36827?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.15.1 |
| `ethyca-fides` | PyPI | All versions | 2.15.1 |
| `ethyca-fides` | PyPI | All versions | 2.15.1 |

Products: Ethyca Fides.

## How do I fix CVE-2023-36827?

Upgrade ethyca-fides to 2.15.1 or later.

## Is CVE-2023-36827 being exploited?

There is no known exploitation of CVE-2023-36827 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36827 and fix it if it is affected.

What it is: CVE-2023-36827 is a high-severity path traversal vulnerability in ethyca fides, published on 5 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36827 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36827/ (Markdown: https://insights.sbomify.com/CVE-2023-36827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36827
- OSV: https://osv.dev/vulnerability/CVE-2023-36827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36827/
Summaries are generated and may contain mistakes; the official description above is the record.
