# CVE-2023-36828: Statamic's Antlers sanitizer cannot effectively sanitize malicious SVG

> Attackers can execute cross-site scripting attacks via malicious SVGs in Statamic CMS, bypassing the sanitizer function.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jul 2023
- **Updated:** 24 Oct 2024
- **Also known as:** GHSA-6r5g-cq4q-327g

## What is CVE-2023-36828?

CVE-2023-36828 is a medium-severity cross-site scripting vulnerability in statamic cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Statamic is a flat-first, Laravel and Git powered content management system. Prior to version 4.10.0, the SVG tag does not sanitize malicious SVG. Therefore, an attacker can exploit this vulnerability to perform cross-site scripting attacks using SVG, even when using the `sanitize` function. Version 4.10.0 contains a patch for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-36828?

2 open source packages ship an affected version, including statamic/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 4.10.0 |
| `statamic/cms` | Packagist | All versions | 4.10.0 |

Products: Statamic Statamic.

## How do I fix CVE-2023-36828?

Upgrade statamic/cms to 4.10.0 or later.

## Is CVE-2023-36828 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36828 exists.

## Other vulnerabilities in statamic cms

- [CVE-2021-45364](https://insights.sbomify.com/CVE-2021-45364/): Code injection in n/a (critical 9.8)
- [CVE-2026-27593](https://insights.sbomify.com/CVE-2026-27593/): Statamic is vulnerable to account takeover via password reset link injection (critical 9.3)
- [CVE-2026-27939](https://insights.sbomify.com/CVE-2026-27939/): Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass (high 8.8)
- [CVE-2023-48217](https://insights.sbomify.com/CVE-2023-48217/): Remote code execution via form uploads in statamic/cms (high 8.8)
- [CVE-2017-11422](https://insights.sbomify.com/CVE-2017-11422/): Statamic framework Incorrect Permission Assignment (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36828 and fix it if it is affected.

What it is: CVE-2023-36828 is a medium-severity cross-site scripting vulnerability in statamic cms, published on 5 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36828 exists.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 4.10.0
- statamic/cms (Packagist): affected all versions; fixed in 4.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36828/ (Markdown: https://insights.sbomify.com/CVE-2023-36828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36828
- OSV: https://osv.dev/vulnerability/CVE-2023-36828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36828/
Summaries are generated and may contain mistakes; the official description above is the record.
