{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-36829 in the wild and no public exploit code.","fix":"Upgrade sentry to 23.6.2 or later.","what":"CVE-2023-36829 is a medium-severity vulnerability in getsentry sentry, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-36829 and fix it if it is affected.\n\nWhat it is: CVE-2023-36829 is a medium-severity vulnerability in getsentry sentry, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-36829 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 23.6.0; fixed in 23.6.2\n- sentry (PyPI): affected from 23.6.0; fixed in 23.6.2\n- sentry (PyPI): affected from 23.6.0; fixed in 23.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36829/ (Markdown: https://insights.sbomify.com/CVE-2023-36829/index.md)","id":"CVE-2023-36829","markdown":"https://insights.sbomify.com/CVE-2023-36829/index.md","name":"CVE-2023-36829","record":{"aliases":["GHSA-4xqm-4p72-87h6","PYSEC-2023-115"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Sentry error tracking","requires_auth":"none","summary":"Sentry API misconfiguration allows credential leakage via CORS if base hostname is set, enabling potential multi-step attacks.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"functional"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"},{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Sentry is an error tracking and performance monitoring platform. Starting in version 23.6.0 and prior to version 23.6.2, the Sentry API incorrectly returns the `access-control-allow-credentials: true` HTTP header if the `Origin` request header ends with the `system.base-hostname` option of Sentry installation. This only affects installations that have `system.base-hostname` option explicitly set, as it is empty by default. Impact is limited since recent versions of major browsers have cross-site cookie blocking enabled by default. However, this flaw could allow other multi-step attacks. The patch has been released in Sentry 23.6.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry CORS misconfiguration vulnerability","id":"CVE-2023-36829","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"misconfiguration","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"SQLFluff vulnerability for users with access to config file, using `library_path` to call arbitrary python code.","id":"CVE-2023-36830"},"packages":[{"ecosystem":"PyPI","fixed":["23.6.2"],"introduced":["23.6.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-4xqm-4p72-87h6"},{"ecosystem":"PyPI","fixed":["23.6.2"],"introduced":["23.6.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-4xqm-4p72-87h6"},{"ecosystem":"PyPI","fixed":["23.6.2"],"introduced":["23.6.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2023-115"}],"prev":{"headline":"Statamic's Antlers sanitizer cannot effectively sanitize malicious SVG","id":"CVE-2023-36828"},"products":["sentry"],"published":"2023-07-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-06","vendors":["getsentry"]},"summary":"Sentry API misconfiguration allows credential leakage via CORS if base hostname is set, enabling potential multi-step attacks.","url":"https://insights.sbomify.com/CVE-2023-36829/"}