# CVE-2023-36830: SQLFluff vulnerability for users with access to config file, using `library_path` to call arbitrary python code.

> Attackers with config file access can execute arbitrary Python code via the library_path setting in SQLFluff.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** DEBIAN-CVE-2023-36830, GHSA-jqhc-m2j3-fjrx, PYSEC-2023-111, UBUNTU-CVE-2023-36830

## What is CVE-2023-36830?

CVE-2023-36830 is a medium-severity code injection vulnerability in sqlfluff, published on 6 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

SQLFluff is a SQL linter. Prior to version 2.1.2, in environments where untrusted users have access to the config files, there is a potential security vulnerability where those users could use the `library_path` config value to allow arbitrary python code to be executed via macros. For many users who use SQLFluff in the context of an environment where all users already have fairly escalated privileges, this may not be an issue - however in larger user bases, or where SQLFluff is bundled into another tool where developers still wish to give users access to supply their on rule configuration, this may be an issue.

The 2.1.2 release offers the ability for the `library_path` argument to be overwritten on the command line by using the `--library-path` option. This overrides any values provided in the config files and effectively prevents this route of attack for users which have access to the config file, but not to the scripts which call the SQLFluff CLI directly. A similar option is provided for the Python API, where users also have a greater ability to further customise or override configuration as necessary. Unless `library_path` is explicitly required, SQLFluff maintainers recommend using the option `--library-path none` when invoking SQLFluff which will disable the `library-path` option entirely regardless of the options set in the configuration file or via inline config directives. As a workaround, limiting access to - or otherwise validating configuration files before they are ingested by SQLFluff will provides a similar effect and does not require upgrade.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-36830?

3 open source packages ship an affected version, including sqlfluff. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlfluff` | PyPI | All versions | 2.1.2 |
| `sqlfluff` | PyPI | All versions | 2.1.2 |
| `sqlfluff` | PyPI | All versions | 2.1.2 |

Products: Sqlfluff Sqlfluff.

## How do I fix CVE-2023-36830?

Upgrade sqlfluff to 2.1.2 or later.

## Is CVE-2023-36830 being exploited?

There is no known exploitation of CVE-2023-36830 in the wild and no public exploit code.

## Other vulnerabilities in sqlfluff

- [CVE-2026-46373](https://insights.sbomify.com/CVE-2026-46373/): SQLFluff: Recursive Stack Overflow in Parser (high 7.5)
- [CVE-2026-46374](https://insights.sbomify.com/CVE-2026-46374/): SQLFluff: Uncontrolled Resource Consumption in Parser (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36830 and fix it if it is affected.

What it is: CVE-2023-36830 is a medium-severity code injection vulnerability in sqlfluff, published on 6 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36830 in the wild and no public exploit code.

Affected packages and fixed versions:
- sqlfluff (PyPI): affected all versions; fixed in 2.1.2
- sqlfluff (PyPI): affected all versions; fixed in 2.1.2
- sqlfluff (PyPI): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36830/ (Markdown: https://insights.sbomify.com/CVE-2023-36830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36830
- OSV: https://osv.dev/vulnerability/CVE-2023-36830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36830/
Summaries are generated and may contain mistakes; the official description above is the record.
