{"answers":{"affected":"2 open source packages ship an affected version, including layui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-3691 in the wild and no public exploit code.","fix":"Upgrade layui to 2.8.0 or later.","what":"CVE-2023-3691 is a low-severity cross-site scripting vulnerability in layui, published on 16 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-3691 and fix it if it is affected.\n\nWhat it is: CVE-2023-3691 is a low-severity cross-site scripting vulnerability in layui, published on 16 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-3691 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- layui (npm): affected all versions; fixed in 2.8.0\n- layui (npm): affected all versions; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3691/ (Markdown: https://insights.sbomify.com/CVE-2023-3691/index.md)","id":"CVE-2023-3691","markdown":"https://insights.sbomify.com/CVE-2023-3691/index.md","name":"CVE-2023-3691","record":{"aliases":["GHSA-hx4h-676r-j3qp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts via the title attribute in the layui library, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"layui","vendor":"layui"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16. This affects an unknown part of the component HTML Attribute Handler. The manipulation of the argument title leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.8.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-234237 was assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"layui HTML Attribute cross site scripting","id":"CVE-2023-3691","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Unrestricted Upload of File with Dangerous Type in admidio/admidio","id":"CVE-2023-3692"},"packages":[{"ecosystem":"npm","fixed":["2.8.0"],"introduced":["0"],"last_affected":[],"package":"layui","purl":null,"source":"GHSA-hx4h-676r-j3qp"},{"ecosystem":"npm","fixed":["2.8.0"],"introduced":["0"],"last_affected":[],"package":"layui","purl":"pkg:npm/layui","source":"GHSA-hx4h-676r-j3qp"}],"prev":{"headline":"Bylancer QuickOrder GET Parameter blog sql injection","id":"CVE-2023-3690"},"products":["layui"],"published":"2023-07-16","related":[{"cvss_score":6.4,"headline":"DOM Clobbering gadgets found in layui that lead to Cross-site Scripting","id":"CVE-2024-47075","kev_date_added":null,"published":"2024-09-26"},{"cvss_score":5.4,"headline":"Layui cross-site scripting (XSS) vulnerability","id":"CVE-2023-50550","kev_date_added":null,"published":"2023-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-23","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via the title attribute in the layui library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2023-3691/"}