# CVE-2023-3700: Authorization Bypass Through User-Controlled Key in alextselegidis/easyappointments

> Attackers can bypass authorization controls by manipulating user-controlled keys to access unauthorized data in Easy Appointments.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-8c6q-26w6-qwhg

## What is CVE-2023-3700?

CVE-2023-3700 is a medium-severity authentication bypass vulnerability in alextselegidis/easyappointments, published on 17 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization Bypass Through User-Controlled Key in GitHub repository alextselegidis/easyappointments prior to 1.5.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2023-3700?

2 open source packages ship an affected version, including alextselegidis/easyappointments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.0 |
| `alextselegidis/easyappointments` | Packagist | All versions | 1.5.0 |

Products: Easyappointments Easyappointments.

## How do I fix CVE-2023-3700?

Upgrade alextselegidis/easyappointments to 1.5.0 or later.

## Is CVE-2023-3700 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3700 exists.

## Other vulnerabilities in alextselegidis/easyappointments

- [CVE-2023-3287](https://insights.sbomify.com/CVE-2023-3287/): A BOLA vulnerability in POST /admins in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38048](https://insights.sbomify.com/CVE-2023-38048/): A BOLA vulnerability in GET, PUT, DELETE /providers/{providerId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38049](https://insights.sbomify.com/CVE-2023-38049/): A BOLA vulnerability in GET, PUT, DELETE /appointments/{appointmentId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38051](https://insights.sbomify.com/CVE-2023-38051/): A BOLA vulnerability in GET, PUT, DELETE /secretaries/{secretaryId} in EasyAppointments < 1.5.0 (critical 9.9)
- [CVE-2023-38052](https://insights.sbomify.com/CVE-2023-38052/): A BOLA vulnerability in GET, PUT, DELETE /admins/{adminId} in EasyAppointments < 1.5.0 (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3700 and fix it if it is affected.

What it is: CVE-2023-3700 is a medium-severity authentication bypass vulnerability in alextselegidis/easyappointments, published on 17 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3700 exists.

Affected packages and fixed versions:
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.0
- alextselegidis/easyappointments (Packagist): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3700/ (Markdown: https://insights.sbomify.com/CVE-2023-3700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3700
- OSV: https://osv.dev/vulnerability/CVE-2023-3700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3700/
Summaries are generated and may contain mistakes; the official description above is the record.
