CVE-2023-37029 Denial of service in n/a

High 7.5 Published Updated

An attacker can crash the Magma MME by sending oversized NAS packets, causing a denial of service for mobile network users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-37029?

CVE-2023-37029 is a high-severity denial of service vulnerability in n/a, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Magma versions <= 1.8.0 (fixed in v1.9 commit 08472ba98b8321f802e95f5622fa90fec2dea486) are susceptible to an assertion-based crash when an oversized NAS packet is received. An attacker may leverage this behavior to repeatedly crash the MME via either a compromised base station or via an unauthenticated cellphone within range of a base station managed by the MME, causing a denial of service.

Weakness: CWE-617

Which versions are affected by CVE-2023-37029?

It affects 1 product.

Products include Linuxfoundation Magma.

How do I fix CVE-2023-37029?

No fix has been published for CVE-2023-37029 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-37029 being exploited?

There is no known exploitation of CVE-2023-37029 in the wild and no public exploit code.

Sources

Also known as GHSA-36m4-mv4f-9c4q.

Is CVE-2023-37029 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free