CVE-2023-3714 ProfileGrid <= 5.5.2 - Missing Authorization to Arbitrary Group Option Modification and Privilege Escalation

High 7.5 Published Updated

Authenticated attackers with group ownership can modify group options and escalate privileges due to missing capability checks in ProfileGrid.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-3714?

CVE-2023-3714 is a high-severity missing authorization vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 18 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The ProfileGrid plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'edit_group' handler in versions up to, and including, 5.5.2. This makes it possible for authenticated attackers, with group ownership, to update group options, including the 'associate_role' parameter, which defines the member's role. This issue was partially patched in version 5.5.2 preventing privilege escalation, however, it was fully patched in 5.5.3.

Weakness: CWE-862

Which versions are affected by CVE-2023-3714?

It affects 1 product.

Products include Metagauss Profilegrid.

How do I fix CVE-2023-3714?

No fix has been published for CVE-2023-3714 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3714 being exploited?

There is no known exploitation of CVE-2023-3714 in the wild and no public exploit code.

Sources

Also known as GHSA-5cr8-3m42-96m7.

Is CVE-2023-3714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free