# CVE-2023-37223: Cross-site scripting in n/a

> Remote authenticated attackers can execute arbitrary code via crafted scripts in Archer Platform, requiring an upgrade to patched versions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AC:L/AV:N/A:N/C:L/I:L/PR:L/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-q2m3-f668-4f3g

## What is CVE-2023-37223?

CVE-2023-37223 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cross Site Scripting (XSS) vulnerability in Archer Platform before v.6.13 and fixed in v.6.12.0.6 and v.6.13.0 allows a remote authenticated attacker to execute arbitrary code via a crafted malicious script.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-37223?

It affects 1 product.


Products: Archerirm Archer.

## How do I fix CVE-2023-37223?

No fix has been published for CVE-2023-37223 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-37223 being exploited?

There is no known exploitation of CVE-2023-37223 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-45358](https://insights.sbomify.com/CVE-2023-45358/): Cross-site scripting in n/a (high 8.5)
- [CVE-2023-32761](https://insights.sbomify.com/CVE-2023-32761/): Cross-site request forgery in n/a (high 8.1)
- [CVE-2023-32760](https://insights.sbomify.com/CVE-2023-32760/): Information disclosure in n/a (high 7.7)
- [CVE-2023-48641](https://insights.sbomify.com/CVE-2023-48641/): Missing authorization in n/a (high 7.5)
- [CVE-2023-32759](https://insights.sbomify.com/CVE-2023-32759/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37223 and fix it if it is affected.

What it is: CVE-2023-37223 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37223 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37223/ (Markdown: https://insights.sbomify.com/CVE-2023-37223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37223
- OSV: https://osv.dev/vulnerability/CVE-2023-37223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37223/
Summaries are generated and may contain mistakes; the official description above is the record.
