# CVE-2023-37255: Cross-site scripting in n/a

> Attackers can inject HTML via User-Agent headers in MediaWiki's CheckUser extension, potentially executing scripts or bypassing security controls.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2023
- **Updated:** 26 Nov 2024
- **Also known as:** BIT-mediawiki-2023-37255, GHSA-c5v4-mrjh-44fj

## What is CVE-2023-37255?

CVE-2023-37255 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3. In Special:CheckUser, a check of the "get edits" type is vulnerable to HTML injection through the User-Agent HTTP request header.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-37255?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.39.4 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2023-37255?

Upgrade mediawiki to 1.39.4 or later.

## Is CVE-2023-37255 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37255 exists.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37255 and fix it if it is affected.

What it is: CVE-2023-37255 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37255 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.39.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37255/ (Markdown: https://insights.sbomify.com/CVE-2023-37255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37255
- OSV: https://osv.dev/vulnerability/CVE-2023-37255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37255/
Summaries are generated and may contain mistakes; the official description above is the record.
