{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37257 exists.","fix":"No fix has been published for CVE-2023-37257 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-37257 is a medium-severity cross-site scripting vulnerability in Dataease Dataease, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-37257 and fix it if it is affected.\n\nWhat it is: CVE-2023-37257 is a medium-severity cross-site scripting vulnerability in Dataease Dataease, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37257 exists.\n\nAffected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37257/ (Markdown: https://insights.sbomify.com/CVE-2023-37257/index.md)","id":"CVE-2023-37257","markdown":"https://insights.sbomify.com/CVE-2023-37257/index.md","name":"CVE-2023-37257","record":{"aliases":["GHSA-7cm3-9pp6-q2fq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DataEase visualization tool","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into DataEase panels and datasets, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"DataEase is an open source data visualization analysis tool. Prior to version 1.18.9, the DataEase panel and dataset have a stored cross-site scripting vulnerability. The vulnerability has been fixed in v1.18.9. There are no known workarounds.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"The DataEase panel and dataset have a stored XSS vulnerability","id":"CVE-2023-37257","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"dataease:dataease","products":["dataease:dataease"],"type":"xss","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"DataEase has a SQL injection vulnerability that can bypass blacklists","id":"CVE-2023-37258"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-37256"},"products":["dataease"],"published":"2023-07-25","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["dataease"]},"summary":"Attackers can inject malicious scripts into DataEase panels and datasets, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2023-37257/"}