# CVE-2023-37263: Strapi's field level permissions not being respected in relationship title

> Strapi fails to enforce field-level permissions in relationship titles, allowing attackers to view restricted data fields.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-m284-85mf-cgrc

## What is CVE-2023-37263?

CVE-2023-37263 is a medium-severity vulnerability in strapi, published on 15 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Strapi is the an open-source headless content management system. Prior to version 4.12.1, field level permissions are not respected in the relationship title. If an actor has relationship title and the relationship shows a field they don't have permission to see, the field will still be visible. Version 4.12.1 has a fix for this issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-37263?

2 open source packages ship an affected version, including @strapi/plugin-content-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-content-manager` | npm | All versions | 4.12.1 |
| `@strapi/plugin-content-manager` | npm | All versions | 4.12.1 |

Products: Strapi Strapi.

## How do I fix CVE-2023-37263?

Upgrade @strapi/plugin-content-manager to 4.12.1 or later.

## Is CVE-2023-37263 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37263 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37263 and fix it if it is affected.

What it is: CVE-2023-37263 is a medium-severity vulnerability in strapi, published on 15 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37263 exists.

Affected packages and fixed versions:
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.12.1
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37263/ (Markdown: https://insights.sbomify.com/CVE-2023-37263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37263
- OSV: https://osv.dev/vulnerability/CVE-2023-37263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37263/
Summaries are generated and may contain mistakes; the official description above is the record.
