# CVE-2023-37269: Winter CMS vulnerable to stored XSS through privileged upload of SVG file

> Privileged users can upload malicious SVGs to execute stored XSS if local storage is used and victims visit the file directly.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-wjw2-4j7j-6gc3

## What is CVE-2023-37269?

CVE-2023-37269 is a low-severity cross-site scripting vulnerability in wintercms winter, published on 7 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Winter is a free, open-source content management system (CMS) based on the Laravel PHP framework. Users with the `backend.manage_branding` permission can upload SVGs as the application logo. Prior to version 1.2.3, SVG uploads were not sanitized, which could have allowed a stored cross-site scripting (XSS) attack. To exploit the vulnerability, an attacker would already need to have developer or super user level permissions in Winter CMS. This means they would already have extensive access and control within the system. Additionally, to execute the XSS, the attacker would need to convince the victim to directly visit the URL of the maliciously uploaded SVG, and the application would have to be using local storage where uploaded files are served under the same domain as the application itself instead of a CDN. This is because all SVGs in Winter CMS are rendered through an `img` tag, which prevents any payloads from being executed directly. These two factors significantly limit the potential harm of this vulnerability. This issue has been patched in v1.2.3 through the inclusion of full support for SVG uploads and automatic sanitization of uploaded SVG files. As a workaround, one may apply the patches manually.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-37269?

2 open source packages ship an affected version, including wintercms/winter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wintercms/winter` | Packagist | All versions | 1.2.3 |
| `wintercms/winter` | Packagist | All versions | 1.2.3 |

Products: Wintercms Winter.

## How do I fix CVE-2023-37269?

Upgrade wintercms/winter to 1.2.3 or later.

## Is CVE-2023-37269 being exploited?

There is no known exploitation of CVE-2023-37269 in the wild and no public exploit code.

Public exploit code:

- WinterCMS < 1.2.3 - Persistent Cross-Site Scripting (exploitdb)

## Other vulnerabilities in wintercms winter

- [CVE-2026-27591](https://insights.sbomify.com/CVE-2026-27591/): Winter: Privilege escalation by authenticated backend users (critical 10.0)
- [CVE-2024-54149](https://insights.sbomify.com/CVE-2024-54149/): Winter CMS Modules allows a sandbox bypass in Twig templates leading to data modification and deletion (high 8.5)
- [CVE-2022-39357](https://insights.sbomify.com/CVE-2022-39357/): Winter vulnerable to Prototype Pollution in Snowboard framework (high 8.1)
- [CVE-2024-29686](https://insights.sbomify.com/CVE-2024-29686/): Winter CMS Server-Side Template Injection (SSTI) vulnerability (high 7.2)
- [CVE-2023-52085](https://insights.sbomify.com/CVE-2023-52085/): Winter CMS Local File Inclusion through Server Side Template Injection (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37269 and fix it if it is affected.

What it is: CVE-2023-37269 is a low-severity cross-site scripting vulnerability in wintercms winter, published on 7 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37269 in the wild and no public exploit code.

Affected packages and fixed versions:
- wintercms/winter (Packagist): affected all versions; fixed in 1.2.3
- wintercms/winter (Packagist): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37269/ (Markdown: https://insights.sbomify.com/CVE-2023-37269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37269
- OSV: https://osv.dev/vulnerability/CVE-2023-37269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37269/
Summaries are generated and may contain mistakes; the official description above is the record.
