# CVE-2023-37273: Docker escape in Auto-GPT when running from docker-compose.yml included in git repo

> Attackers can execute arbitrary code to overwrite configuration files, enabling container escape and host system compromise in Auto-GPT.

- **Severity:** High 8.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-x5gj-2chr-4ch6

## What is CVE-2023-37273?

CVE-2023-37273 is a high-severity code injection vulnerability in Significant-Gravitas Auto-GPT, published on 13 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. Running Auto-GPT version prior to 0.4.3 by cloning the git repo and executing `docker compose run auto-gpt` in the repo root uses a different docker-compose.yml file from the one suggested in the official docker set up instructions. The docker-compose.yml file located in the repo root mounts itself into the docker container without write protection. This means that if malicious custom python code is executed via the `execute_python_file` and `execute_python_code` commands, it can overwrite the docker-compose.yml file and abuse it to gain control of the host system the next time Auto-GPT is started. The issue has been patched in version 0.4.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-37273?

It affects 1 product.


Products: Agpt Autogpt Classic.

## How do I fix CVE-2023-37273?

No fix has been published for CVE-2023-37273 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-37273 being exploited?

There is no known exploitation of CVE-2023-37273 in the wild and no public exploit code.

Public exploit code:

- Site containing info useful for demonstrate CVE-2023-37273 (github_poc): https://github.com/gdesantis01/instructions-summarizing

## Other vulnerabilities in Significant-Gravitas Auto-GPT

- [CVE-2024-6091](https://insights.sbomify.com/CVE-2024-6091/): Shell Command Denylist Bypass in significant-gravitas/autogpt (critical 9.8)
- [CVE-2024-8156](https://insights.sbomify.com/CVE-2024-8156/): Command Injection in significant-gravitas/autogpt (high 8.8)
- [CVE-2024-1879](https://insights.sbomify.com/CVE-2024-1879/): CSRF to RCE in significant-gravitas/autogpt (high 8.8)
- [CVE-2024-1881](https://insights.sbomify.com/CVE-2024-1881/): Improper Neutralization of Special Elements used in an OS Command in significant-gravitas/autogpt (high 8.8)
- [CVE-2024-1880](https://insights.sbomify.com/CVE-2024-1880/): OS Command Injection in MacOS Text-To-Speech Class in significant-gravitas/autogpt (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37273 and fix it if it is affected.

What it is: CVE-2023-37273 is a high-severity code injection vulnerability in Significant-Gravitas Auto-GPT, published on 13 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37273 in the wild and no public exploit code.

Affected product: Significant-Gravitas Auto-GPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37273/ (Markdown: https://insights.sbomify.com/CVE-2023-37273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37273
- OSV: https://osv.dev/vulnerability/CVE-2023-37273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37273/
Summaries are generated and may contain mistakes; the official description above is the record.
