# CVE-2023-37274: Python code execution sandbox escape in non-docker version in Auto-GPT

> Path traversal in Auto-GPT allows overwriting host files to escape sandbox and execute arbitrary code on the host system.

- **Severity:** High 7.6 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Jul 2023
- **Updated:** 30 Oct 2024
- **Also known as:** GHSA-5h38-mgp9-rj5f

## What is CVE-2023-37274?

CVE-2023-37274 is a high-severity path traversal vulnerability in Significant-Gravitas Auto-GPT, published on 13 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. When Auto-GPT is executed directly on the host system via the provided run.sh or run.bat files, custom Python code execution is sandboxed using a temporary dedicated docker container which should not have access to any files outside of the Auto-GPT workspace directory.
Before v0.4.3, the `execute_python_code` command (introduced in v0.4.1) does not sanitize the `basename` arg before writing LLM-supplied code to a file with an LLM-supplied name. This allows for a path traversal attack that can overwrite any .py file outside the workspace directory by specifying a `basename` such as `../../../main.py`. This can further be abused to achieve arbitrary code execution on the host running Auto-GPT by e.g. overwriting autogpt/main.py which will be executed outside of the docker environment meant to sandbox custom python code execution the next time Auto-GPT is started. The issue has been patched in version 0.4.3. As a workaround, the risk introduced by this vulnerability can be remediated by running Auto-GPT in a virtual machine, or another environment in which damage to files or corruption of the program is not a critical problem.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-37274?

It affects 1 product.


Products: Agpt Autogpt Classic.

## How do I fix CVE-2023-37274?

No fix has been published for CVE-2023-37274 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-37274 being exploited?

There is no known exploitation of CVE-2023-37274 in the wild and no public exploit code.

## Other vulnerabilities in Significant-Gravitas Auto-GPT

- [CVE-2024-6091](https://insights.sbomify.com/CVE-2024-6091/): Shell Command Denylist Bypass in significant-gravitas/autogpt (critical 9.8)
- [CVE-2024-8156](https://insights.sbomify.com/CVE-2024-8156/): Command Injection in significant-gravitas/autogpt (high 8.8)
- [CVE-2024-1879](https://insights.sbomify.com/CVE-2024-1879/): CSRF to RCE in significant-gravitas/autogpt (high 8.8)
- [CVE-2024-1881](https://insights.sbomify.com/CVE-2024-1881/): Improper Neutralization of Special Elements used in an OS Command in significant-gravitas/autogpt (high 8.8)
- [CVE-2023-37273](https://insights.sbomify.com/CVE-2023-37273/): Docker escape in Auto-GPT when running from docker-compose.yml included in git repo (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37274 and fix it if it is affected.

What it is: CVE-2023-37274 is a high-severity path traversal vulnerability in Significant-Gravitas Auto-GPT, published on 13 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37274 in the wild and no public exploit code.

Affected product: Significant-Gravitas Auto-GPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37274/ (Markdown: https://insights.sbomify.com/CVE-2023-37274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37274
- OSV: https://osv.dev/vulnerability/CVE-2023-37274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37274/
Summaries are generated and may contain mistakes; the official description above is the record.
