# CVE-2023-37277: XWiki Platform vulnerable to cross-site request forgery (CSRF) via the REST API

> Attackers can perform CSRF attacks via the REST API to achieve remote code execution if a user with programming rights interacts with a malicious form.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2023
- **Updated:** 8 Nov 2024
- **Also known as:** GHSA-6xxr-648m-gch6

## What is CVE-2023-37277?

CVE-2023-37277 is a critical vulnerability in Xwiki Xwiki, published on 10 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. The REST API allows executing all actions via POST requests and accepts `text/plain`, `multipart/form-data` or `application/www-form-urlencoded` as content types which can be sent via regular HTML forms, thus allowing cross-site request forgery. With the interaction of a user with programming rights, this allows remote code execution through script macros and thus impacts the integrity, availability and confidentiality of the whole XWiki installation. For regular cookie-based authentication, the vulnerability is mitigated by SameSite cookie restrictions but as of March 2023, these are not enabled by default in Firefox and Safari. The vulnerability has been patched in XWiki 14.10.8 and 15.2 by requiring a CSRF token header for certain request types that are susceptible to CSRF attacks.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-37277?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server, com.xpn.xwiki.platform:xwiki-core-rest-server and com.xpn.xwiki.platform:xwiki-rest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8 | 14.10.8 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8 | 14.10.8 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.0-rc-1 | 15.2 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.0-rc-1 | 15.2 |
| `com.xpn.xwiki.platform:xwiki-core-rest-server` | Maven | From 1.8 | 14.10.8 |
| `com.xpn.xwiki.platform:xwiki-core-rest-server` | Maven | From 1.8 | 14.10.8 |
| `com.xpn.xwiki.platform:xwiki-rest` | Maven | From 1.8 | 14.10.8 |
| `com.xpn.xwiki.platform:xwiki-rest` | Maven | From 1.8 | 14.10.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-37277?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 14.10.8 or 15.2.

## Is CVE-2023-37277 being exploited?

There is no known exploitation of CVE-2023-37277 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37277 and fix it if it is affected.

What it is: CVE-2023-37277 is a critical vulnerability in Xwiki Xwiki, published on 10 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37277 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8; fixed in 14.10.8
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8; fixed in 14.10.8
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.0-rc-1; fixed in 15.2
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.0-rc-1; fixed in 15.2
- com.xpn.xwiki.platform:xwiki-core-rest-server (Maven): affected from 1.8; fixed in 14.10.8
- com.xpn.xwiki.platform:xwiki-core-rest-server (Maven): affected from 1.8; fixed in 14.10.8
- com.xpn.xwiki.platform:xwiki-rest (Maven): affected from 1.8; fixed in 14.10.8
- com.xpn.xwiki.platform:xwiki-rest (Maven): affected from 1.8; fixed in 14.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37277/ (Markdown: https://insights.sbomify.com/CVE-2023-37277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37277
- OSV: https://osv.dev/vulnerability/CVE-2023-37277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37277/
Summaries are generated and may contain mistakes; the official description above is the record.
