{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-37280 in the wild and no public exploit code.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.0.3 or later.","what":"CVE-2023-37280 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 11 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37280 and fix it if it is affected.\n\nWhat it is: CVE-2023-37280 is a medium-severity cross-site scripting vulnerability in pimcore admin-ui-classic-bundle, published on 11 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-37280 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.0.3\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37280/ (Markdown: https://insights.sbomify.com/CVE-2023-37280/index.md)","id":"CVE-2023-37280","markdown":"https://insights.sbomify.com/CVE-2023-37280/index.md","name":"CVE-2023-37280","record":{"aliases":["GHSA-hqv9-6jqw-9g8m"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Pimcore admin UI","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in the Pimcore admin UI if two-factor authentication is not yet configured, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"admin_classic_bundle","vendor":"pimcore"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pimcore Admin Classic Bundle provides a Backend UI for Pimcore based on the ExtJS framework. An admin who has not setup two factor authentication before is vulnerable for this attack, without need for any form of privilege, causing the application to execute arbitrary scripts/HTML content. This vulnerability has been patched in version 1.0.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pimcore admin UI vulnerable to Cross-site Scripting in two factor authentication setup page","id":"CVE-2023-37280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Out-of-bounds read during IPHC address decompression","id":"CVE-2023-37281"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-hqv9-6jqw-9g8m"},{"ecosystem":"Packagist","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-hqv9-6jqw-9g8m"}],"prev":{"headline":"Faktory Web Dashboard can lead to denial of service(DOS) via malicious user input","id":"CVE-2023-37279"},"products":["admin-ui-classic-bundle"],"published":"2023-07-11","related":[{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.5,"headline":"Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls","id":"CVE-2023-49075","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":8.1,"headline":"Pimcore Host Header Injection in user invitation link","id":"CVE-2024-25625","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":6.9,"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":6.5,"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":6.3,"headline":"Pimcore vulnerable to disclosure of system and database information behind /admin firewall","id":"CVE-2024-41109","kev_date_added":null,"published":"2024-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-23","vendors":["pimcore"]},"summary":"An attacker can execute arbitrary scripts in the Pimcore admin UI if two-factor authentication is not yet configured, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2023-37280/"}