{"answers":{"affected":"3 open source packages ship an affected version, including mediawiki and wikibase/wikibase. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37302 exists.","fix":"Upgrade mediawiki to 1.39.4 or later.","what":"CVE-2023-37302 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-37302 and fix it if it is affected.\n\nWhat it is: CVE-2023-37302 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37302 exists.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.39.4\n- wikibase/wikibase (Packagist): affected all versions up to 1.39.3; no fix listed\n- wikibase/wikibase (Packagist): affected all versions up to 1.39.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37302/ (Markdown: https://insights.sbomify.com/CVE-2023-37302/index.md)","id":"CVE-2023-37302","markdown":"https://insights.sbomify.com/CVE-2023-37302/index.md","name":"CVE-2023-37302","record":{"aliases":["BIT-mediawiki-2023-37302","GHSA-fmrf-p77g-vv5c","UBUNTU-CVE-2023-37302"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki Wikibase","requires_auth":"none","summary":"Cross-site scripting vulnerability in MediaWiki Wikibase allows attackers to inject malicious scripts via crafted badge titles, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in SiteLinksView.php in Wikibase in MediaWiki through 1.39.3. There is XSS via a crafted badge title attribute. This is also related to lack of escaping in wbTemplate (from resources/wikibase/templates.js) for quotes (which can be in a title attribute).","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MediaWiki Cross-site Scripting vulnerability","id":"CVE-2023-37302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mediawiki:mediawiki","products":["mediawiki:mediawiki"],"type":"xss","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-37303"},"packages":[{"ecosystem":"Bitnami","fixed":["1.39.4"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2023-37302"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.39.3"],"package":"wikibase/wikibase","purl":null,"source":"GHSA-fmrf-p77g-vv5c"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.39.3"],"package":"wikibase/wikibase","purl":"pkg:composer/wikibase/wikibase","source":"GHSA-fmrf-p77g-vv5c"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2023-37301"},"products":["n/a"],"published":"2023-06-30","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2023-37303","kev_date_added":null,"published":"2023-06-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-29904","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-29906","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2022-28205","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28206","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28209","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2021-36126","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in MediaWiki Wikibase allows attackers to inject malicious scripts via crafted badge titles, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2023-37302/"}