{"answers":{"affected":"1 open source package ship an affected version, including pacparser. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37360 exists.","fix":"Upgrade pacparser to 1.4.2 or later.","what":"CVE-2023-37360 is a medium-severity code injection vulnerability in n/a, published on 30 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37360 and fix it if it is affected.\n\nWhat it is: CVE-2023-37360 is a medium-severity code injection vulnerability in n/a, published on 30 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37360 exists.\n\nAffected packages and fixed versions:\n- pacparser (PyPI): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37360/ (Markdown: https://insights.sbomify.com/CVE-2023-37360/index.md)","id":"CVE-2023-37360","markdown":"https://insights.sbomify.com/CVE-2023-37360/index.md","name":"CVE-2023-37360","record":{"aliases":["DEBIAN-CVE-2023-37360","GHSA-62q6-v997-f7v9","GHSA-jw9q-h95v-3wgq","PYSEC-2023-93","UBUNTU-CVE-2023-37360"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Pacparser library","requires_auth":"none","summary":"Attackers can inject JavaScript via controlled URLs in Pacparser, potentially leading to code execution and privilege escalation in enterprise security products.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pacparser","vendor":"pacparser_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:N/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Code injection in n/a","id":"CVE-2023-37360","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":1,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2023-37361"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"pacparser","purl":"pkg:pypi/pacparser","source":"PYSEC-2023-93"}],"prev":{"headline":"Kofax Power PDF U3D File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability","id":"CVE-2023-37359"},"products":["n/a"],"published":"2023-06-30","related":[{"cvss_score":5.3,"headline":"pacparser pacparser.c pacparser_find_proxy buffer overflow","id":"CVE-2019-25078","kev_date_added":null,"published":"2022-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["n/a"]},"summary":"Attackers can inject JavaScript via controlled URLs in Pacparser, potentially leading to code execution and privilege escalation in enterprise security products.","url":"https://insights.sbomify.com/CVE-2023-37360/"}