# CVE-2023-37360: Code injection in n/a

> Attackers can inject JavaScript via controlled URLs in Pacparser, potentially leading to code execution and privilege escalation in enterprise security products.

- **Severity:** Medium 5.9 (`CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 26 Nov 2024
- **Also known as:** DEBIAN-CVE-2023-37360, GHSA-62q6-v997-f7v9, GHSA-jw9q-h95v-3wgq, PYSEC-2023-93, UBUNTU-CVE-2023-37360

## What is CVE-2023-37360?

CVE-2023-37360 is a medium-severity code injection vulnerability in n/a, published on 30 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-37360?

1 open source package ship an affected version, including pacparser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pacparser` | PyPI | All versions | 1.4.2 |

Products: Pacparser Project Pacparser.

## How do I fix CVE-2023-37360?

Upgrade pacparser to 1.4.2 or later.

## Is CVE-2023-37360 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37360 exists.

## Other vulnerabilities in n/a

- [CVE-2019-25078](https://insights.sbomify.com/CVE-2019-25078/): pacparser pacparser.c pacparser_find_proxy buffer overflow (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37360 and fix it if it is affected.

What it is: CVE-2023-37360 is a medium-severity code injection vulnerability in n/a, published on 30 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37360 exists.

Affected packages and fixed versions:
- pacparser (PyPI): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37360/ (Markdown: https://insights.sbomify.com/CVE-2023-37360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37360
- OSV: https://osv.dev/vulnerability/CVE-2023-37360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37360/
Summaries are generated and may contain mistakes; the official description above is the record.
