# CVE-2023-37365: hnswlib Double Free vulnerability

> A double free vulnerability in Hnswlib allows attackers to cause denial of service or potentially execute code via a large M argument.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 5 Dec 2024
- **Also known as:** DEBIAN-CVE-2023-37365, GHSA-xwc8-rf6m-xr86, PYSEC-2026-1450, UBUNTU-CVE-2023-37365

## What is CVE-2023-37365?

CVE-2023-37365 is a medium-severity memory corruption vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hnswlib 0.7.0 has a double free in init_index when the M argument is a large integer.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2023-37365?

3 open source packages ship an affected version, including hnswlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hnswlib` | PyPI | All versions | 0.8.0 |
| `hnswlib` | PyPI | All versions | 0.8.0 |
| `hnswlib` | PyPI | All versions | 0.8.0 |

Products: Hnswlib Project Hnswlib.

## How do I fix CVE-2023-37365?

Upgrade hnswlib to 0.8.0 or later.

## Is CVE-2023-37365 being exploited?

There is no known exploitation of CVE-2023-37365 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37365 and fix it if it is affected.

What it is: CVE-2023-37365 is a medium-severity memory corruption vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37365 in the wild and no public exploit code.

Affected packages and fixed versions:
- hnswlib (PyPI): affected all versions; fixed in 0.8.0
- hnswlib (PyPI): affected all versions; fixed in 0.8.0
- hnswlib (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37365/ (Markdown: https://insights.sbomify.com/CVE-2023-37365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37365
- OSV: https://osv.dev/vulnerability/CVE-2023-37365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37365/
Summaries are generated and may contain mistakes; the official description above is the record.
