{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37369 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-37369 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 20 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37369 and fix it if it is affected.\n\nWhat it is: CVE-2023-37369 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 20 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37369 exists.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37369/ (Markdown: https://insights.sbomify.com/CVE-2023-37369/index.md)","id":"CVE-2023-37369","markdown":"https://insights.sbomify.com/CVE-2023-37369/index.md","name":"CVE-2023-37369","record":{"aliases":["AZL-27920","DEBIAN-CVE-2023-37369","GHSA-h6px-w542-49xj","OESA-2023-1610","SUSE-SU-2023:4950-1","SUSE-SU-2023:4951-1","UBUNTU-CVE-2023-37369","openSUSE-SU-2024:13470-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt XML library","requires_auth":"none","summary":"An attacker can cause an application crash in Qt's QXmlStreamReader by providing a crafted XML string, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"qt","vendor":"qt"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"In Qt before 5.15.15, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.2, there can be an application crash in QXmlStreamReader via a crafted XML string that triggers a situation in which a prefix is greater than a length.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP4","SUSE:Linux Enterprise Module for Basesystem 15 SP5","SUSE:Linux Enterprise Module for Desktop Applications 15 SP4","SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","openSUSE:Leap 15.4","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-37369","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","qt:qt"],"type":"denial_of_service","year":"2023"},"n_packages":7,"n_references":6,"next":{"headline":"SQL injection in RUGGEDCOM CROSSBOW","id":"CVE-2023-37372"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP4","fixed":["5.15.2+kde294-150400.6.10.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP4","source":"SUSE-SU-2023:4950-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP5","fixed":["5.15.8+kde185-150500.4.13.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP5","source":"SUSE-SU-2023:4951-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP4","fixed":["5.15.2+kde294-150400.6.10.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP4","source":"SUSE-SU-2023:4950-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","fixed":["5.15.8+kde185-150500.4.13.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/suse/libqt5-qtbase\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP5","source":"SUSE-SU-2023:4951-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["5.15.2+kde294-150400.6.10.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:4950-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["5.15.8+kde185-150500.4.13.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:4951-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.11+kde138-3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13470-1"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2023-37368"},"products":["n/a"],"published":"2023-08-20","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker can cause an application crash in Qt's QXmlStreamReader by providing a crafted XML string, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2023-37369/"}