# CVE-2023-37379: Apache Airflow: Exposure of sensitive connection information, DOS and SSRF on "test connection" feature

> Authenticated users with connection edit privileges can expose sensitive data, cause denial of service, or perform SSRF via the test connection feature.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-37379, GHSA-x2mh-8fmc-rqgh, PYSEC-2023-152

## What is CVE-2023-37379?

CVE-2023-37379 is a high-severity server-side request forgery vulnerability in Apache Airflow, published on 23 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server.

Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-400 (Uncontrolled Resource Consumption), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-37379?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.7.0 |
| `apache-airflow` | PyPI | All versions | 2.7.0b1 |
| `apache-airflow` | PyPI | All versions | 2.7.0b1 |
| `airflow` | Bitnami | All versions | 2.7.0 |

Products: Apache Airflow.

## How do I fix CVE-2023-37379?

Upgrade apache-airflow to a fixed version for your release line: 2.7.0 or 2.7.0b1.

## Is CVE-2023-37379 being exploited?

There is no known exploitation of CVE-2023-37379 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37379 and fix it if it is affected.

What it is: CVE-2023-37379 is a high-severity server-side request forgery vulnerability in Apache Airflow, published on 23 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37379 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0b1
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0b1
- airflow (Bitnami): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37379/ (Markdown: https://insights.sbomify.com/CVE-2023-37379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37379
- OSV: https://osv.dev/vulnerability/CVE-2023-37379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37379/
Summaries are generated and may contain mistakes; the official description above is the record.
