{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-federation-library. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-37471 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-federation-library to 14.7.3 or later.","what":"CVE-2023-37471 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 20 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37471 and fix it if it is affected.\n\nWhat it is: CVE-2023-37471 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 20 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-37471 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-federation-library (Maven): affected all versions; fixed in 14.7.3\n- org.openidentityplatform.openam:openam-federation-library (Maven): affected all versions; fixed in 14.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37471/ (Markdown: https://insights.sbomify.com/CVE-2023-37471/index.md)","id":"CVE-2023-37471","markdown":"https://insights.sbomify.com/CVE-2023-37471/index.md","name":"CVE-2023-37471","record":{"aliases":["GHSA-4mh8-9wq6-rjxg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"Attackers can impersonate any user, including administrators, by sending crafted SAML responses due to improper signature validation in OpenAM.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openam","vendor":"openidentityplatform"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Open Access Management (OpenAM) is an access management solution that includes Authentication, SSO, Authorization, Federation, Entitlements and Web Services Security. OpenAM up to version 14.7.2 does not properly validate the signature of SAML responses received as part of the SAMLv1.x Single Sign-On process. Attackers can use this fact to impersonate any OpenAM user, including the administrator, by sending a specially crafted SAML response to the SAMLPOSTProfileServlet servlet. This problem has been patched in  OpenAM 14.7.3-SNAPSHOT and later. User unable to upgrade should comment servlet `SAMLPOSTProfileServlet` from their pom file. See the linked GHSA for details.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User impersonation using SAMLv1.x SSO in Open Access Management","id":"CVE-2023-37471","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Query injection in Knowage server","id":"CVE-2023-37472"},"packages":[{"ecosystem":"Maven","fixed":["14.7.3"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-federation-library","purl":null,"source":"GHSA-4mh8-9wq6-rjxg"},{"ecosystem":"Maven","fixed":["14.7.3"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-federation-library","purl":"pkg:maven/org.openidentityplatform.openam/openam-federation-library","source":"GHSA-4mh8-9wq6-rjxg"}],"prev":{"headline":"Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint","id":"CVE-2023-37470"},"products":["OpenAM"],"published":"2023-07-20","related":[{"cvss_score":9.3,"headline":"Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM","id":"CVE-2026-33439","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":5.3,"headline":"NT auth module vulnerability in OpenAM","id":"CVE-2022-34298","kev_date_added":null,"published":"2022-06-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-24","vendors":["OpenIdentityPlatform"]},"summary":"Attackers can impersonate any user, including administrators, by sending crafted SAML responses due to improper signature validation in OpenAM.","url":"https://insights.sbomify.com/CVE-2023-37471/"}