# CVE-2023-37473: Limited code execution in zenstruck/collections


- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-7xr2-8ff7-6fjq

## What is CVE-2023-37473?

CVE-2023-37473 is a high-severity vulnerability in zenstruck collection, published on 14 Jul 2023. 

### Official description

zenstruck/collections is a set of helpers for iterating/paginating/filtering collections. Passing _callable strings_ (ie `system`) caused the function to be executed. This would result in a limited subset of specific user input being executed as if it were code. This issue has been addressed in commit `f4b1c48820` and included in release version 0.2.1. Users are advised to upgrade. Users unable to upgrade should ensure that user input is not passed to either `EntityRepository::find()` or `query()`.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-37473?

2 open source packages ship an affected version, including zenstruck/collection. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenstruck/collection` | Packagist | All versions | 0.2.1 |
| `zenstruck/collection` | Packagist | All versions | 0.2.1 |

Products: Zenstruck Collection.

## How do I fix CVE-2023-37473?

Upgrade zenstruck/collection to 0.2.1 or later.

## Is CVE-2023-37473 being exploited?

There is no known exploitation of CVE-2023-37473 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37473 and fix it if it is affected.

What it is: CVE-2023-37473 is a high-severity vulnerability in zenstruck collection, published on 14 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2023-37473 in the wild and no public exploit code.

Affected packages and fixed versions:
- zenstruck/collection (Packagist): affected all versions; fixed in 0.2.1
- zenstruck/collection (Packagist): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37473/ (Markdown: https://insights.sbomify.com/CVE-2023-37473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37473
- OSV: https://osv.dev/vulnerability/CVE-2023-37473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37473/
Summaries are generated and may contain mistakes; the official description above is the record.
