# CVE-2023-37477: Command injection in firewall ip functionality in 1Panel

> Authenticated attackers can execute arbitrary system commands via the firewall IP endpoint, leading to full system compromise.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-p9xf-74xh-mhw5, GO-2023-1940

## What is CVE-2023-37477?

CVE-2023-37477 is a high-severity command injection vulnerability in 1Panel-dev 1Panel, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

1Panel is an open source Linux server operation and maintenance management panel. An OS command injection vulnerability exists in 1Panel firewall functionality. A specially-crafted HTTP request can lead to arbitrary command execution. An attacker can make an authenticated HTTP request to trigger this vulnerability. 1Panel firewall functionality `/hosts/firewall/ip` endpoint read user input without validation, the attacker extends the default functionality of the application, which execute system commands. An attacker can execute arbitrary code on the target system, which can lead to a complete compromise of the system. This issue has been addressed in commit `e17b80cff49` which is included in release version `1.4.3`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-37477?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.4.3 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.4.3 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.4.3 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2023-37477?

Upgrade github.com/1Panel-dev/1Panel to 1.4.3 or later.

## Is CVE-2023-37477 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37477 exists.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37477 and fix it if it is affected.

What it is: CVE-2023-37477 is a high-severity command injection vulnerability in 1Panel-dev 1Panel, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37477 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.4.3
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.4.3
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37477/ (Markdown: https://insights.sbomify.com/CVE-2023-37477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37477
- OSV: https://osv.dev/vulnerability/CVE-2023-37477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37477/
Summaries are generated and may contain mistakes; the official description above is the record.
