CVE-2023-37480 Fides Webserver Vulnerable to Zip Bomb File Uploads
Privileged users can upload zip bomb files to the Fides webserver, causing resource exhaustion and service unavailability for all users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37480?
CVE-2023-37480 is a low-severity denial of service vulnerability in ethyca fides, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit a weakness in the connector template upload feature to upload a malicious zip bomb file, resulting in resource exhaustion and service unavailability for all users of the Fides webserver. This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading. If an attack occurs, the impact can be mitigated by manually or automatically restarting the affected container.
Weakness: CWE-400
Which versions are affected by CVE-2023-37480?
3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ethyca-fides PyPI | From 2.11.0 | 2.16.0 |
ethyca-fides PyPI | From 2.11.0 | 2.16.0 |
ethyca-fides PyPI | From 2.11.0 | 2.16.0 |
Products include Ethyca Fides.
How do I fix CVE-2023-37480?
Upgrade ethyca-fides to 2.16.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-37480 being exploited?
There is no known exploitation of CVE-2023-37480 in the wild and no public exploit code.
Other vulnerabilities in ethyca fides
- CVE-2024-45053 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine
- CVE-2023-41319 Remote Code Execution in Custom Integration Upload in Fides
- CVE-2025-57817 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation
- CVE-2023-48224 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides
- CVE-2023-46124 Server-Side Request Forgery Vulnerability in Custom Integration Upload
Sources
Also known as GHSA-g95c-2jgm-hqc6, PYSEC-2026-1342.