CVE-2023-37481 Fides Webserver Vulnerable to SVG Bomb File Uploads

Low 2.7 Published Updated

Privileged users can upload malicious SVG bombs causing resource exhaustion and denial of service in the Admin UI.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-37481?

CVE-2023-37481 is a low-severity denial of service vulnerability in ethyca fides, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading.

Weakness: CWE-400

Which versions are affected by CVE-2023-37481?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.

PackageAffectedFixed in
ethyca-fides PyPIFrom 2.11.02.16.0
ethyca-fides PyPIFrom 2.11.02.16.0
ethyca-fides PyPIFrom 2.11.02.16.0

Products include Ethyca Fides.

How do I fix CVE-2023-37481?

Upgrade ethyca-fides to 2.16.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-37481 being exploited?

There is no known exploitation of CVE-2023-37481 in the wild and no public exploit code.

Sources

Also known as GHSA-3rw2-wfc8-wmj5, PYSEC-2026-1332.

Is CVE-2023-37481 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free