# CVE-2023-37481: Fides Webserver Vulnerable to SVG Bomb File Uploads

> Privileged users can upload malicious SVG bombs causing resource exhaustion and denial of service in the Admin UI.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-3rw2-wfc8-wmj5, PYSEC-2026-1332

## What is CVE-2023-37481?

CVE-2023-37481 is a low-severity denial of service vulnerability in ethyca fides, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-37481?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.11.0 | 2.16.0 |
| `ethyca-fides` | PyPI | From 2.11.0 | 2.16.0 |
| `ethyca-fides` | PyPI | From 2.11.0 | 2.16.0 |

Products: Ethyca Fides.

## How do I fix CVE-2023-37481?

Upgrade ethyca-fides to 2.16.0 or later.

## Is CVE-2023-37481 being exploited?

There is no known exploitation of CVE-2023-37481 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37481 and fix it if it is affected.

What it is: CVE-2023-37481 is a low-severity denial of service vulnerability in ethyca fides, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37481 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.11.0; fixed in 2.16.0
- ethyca-fides (PyPI): affected from 2.11.0; fixed in 2.16.0
- ethyca-fides (PyPI): affected from 2.11.0; fixed in 2.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37481/ (Markdown: https://insights.sbomify.com/CVE-2023-37481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37481
- OSV: https://osv.dev/vulnerability/CVE-2023-37481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37481/
Summaries are generated and may contain mistakes; the official description above is the record.
